General - Collecting Stack Trace
If we have any native debugger installed collect the stack trace. Try to generate stack trace from core file for all the threads dumped.- SOLARIS
- pstack core or
- /opt/SUNWspro/bin/dbx program core
- (dbx) thread -info t@1 ==> show the thread information
(dbx) where ==> show the thread stack AIX - The syscorepath utility can be used to specify a single system-wide directory in which all core files of any processes are saved. The syntax for this command is: syscorepath -p alternate_directory.
- To set the OS for full core dumps and files to unlimited
- Set the ulimit setting for core dumps to unlimited: ulimit -c unlimited.
- Set the ulimit setting for core files to unlimited: ulimit -f unlimited.
- Set Smit to use full core dumps either by starting smit and setting: System Environments -> Change/Show Characteristics of Operating System -> Enable Full CORE dump to "TRUE", or by using the command chdev -l sys0 -a fullcore='true' as root.
- Ensure that the current working directory has enough disk space available to write the core file. You can redirect AIX core files to alternative locations using a symbolic link. To do this, you must create a link from the current working directory of the process to an alternative directory where there is a file called "core". After a full core file has been generated and located, you must rename that file to prevent any other core file, that is generated in the same directory, from overwriting it.
- Run SMIT (or smitty) --> System Environments --> Change / Show Characteristics of Operating System --> Use pre-430 style CORE dump. Set the last option to true and then adb / dbx will be able to read new core files produced (the core file must be created under new settings).
- LINUX
- gdb program core
- (gdb) where
- HPUX
- adb programname core
- (adb) $c
About this entry
You’re currently reading “
- Published:
- 2:55 am
- by -
0 Comments (Post a Comment)